Problems with all Microsoft Apps

Here you can report bugs you may find in ShellEnhancer.

Moderators: Marc G, Johan G

Problems with all Microsoft Apps

Postby shep1549 » Fri Oct 08, 2004 12:21 pm

I am running the SP2 for Win XP and Ofc XP with latest patches. With any MS Ofc or MS App, save as causes errors with app and doc is not saved. Also noticed that some of the popup windows for MS Apps, particularly Word Customize toolbar, will not close and stop the app from responding.

If Shell Ehn is closed then all works fine. I haven't been able to find a setting to cure this. Transparency is not enabled. Only the basic features are being used.
Shep
shep1549
 
Posts: 11
Joined: Fri Oct 08, 2004 12:14 pm

Postby Marc G » Fri Oct 08, 2004 3:46 pm

Thanks for the bug-report.
I'll look into it, although I find it really strange because I'm using Windows XP SP2 myself without any problems.
Marc Gregoire,
NuonSoft
[ Microsoft MVP VC++ since 2007 ]
User avatar
Marc G
NuonSoft Staff
 
Posts: 826
Joined: Thu Nov 07, 2002 8:19 pm
Location: Belgium

Further note

Postby shep1549 » Fri Oct 08, 2004 4:55 pm

The problem seems to be with any secondary window that opens up after the initial window for the app. The window does appear to close but the app thinks it is still open. When saving a file, I believe the app locks because the save as window closes but the folder is somehow locked open and the app can't save to it. Somehow Shell Ehn is causing this problem. Is there a way to exclude certain apps from SE.

Thought it might be the task switcher so I disabled it. No luck. It just seems to be with any common dialog window. Well check and make sure I have the latest.
Shep
shep1549
 
Posts: 11
Joined: Fri Oct 08, 2004 12:14 pm

Postby Marc G » Fri Oct 08, 2004 5:19 pm

There is no way to exclude apps currently.

Are you running ShellEnhancer 1.0 Beta? If so, there is a 2.0 beta available. Please try it.
Marc Gregoire,
NuonSoft
[ Microsoft MVP VC++ since 2007 ]
User avatar
Marc G
NuonSoft Staff
 
Posts: 826
Joined: Thu Nov 07, 2002 8:19 pm
Location: Belgium

Postby shep1549 » Fri Oct 08, 2004 9:09 pm

No I am running the 2.0 beta. I also checked the comdlg.dll and it is current. So Not sure what is going on. I know I just did updates for MS Ofc XP and for Win XP. So maybe they have something to do with it. When I can I will deinstall and reinstall.
Shep
shep1549
 
Posts: 11
Joined: Fri Oct 08, 2004 12:14 pm

Found Problem

Postby shep1549 » Tue Oct 12, 2004 8:22 pm

The problem was another SW app that managed the "save/save as" dialog window size. I unloaded it and now every thing is working fine.
Does shell enhancer have a way of making this windows permanently larger than they are? :D

p.s. The program was "File_ex" by Cottonwood Software.
url: http://www.cottonwoodsw.com
Shep
shep1549
 
Posts: 11
Joined: Fri Oct 08, 2004 12:14 pm

Postby Marc G » Wed Oct 13, 2004 1:33 pm

Ah, ok, i'm glad the issue is resolved :D

No, ShellEnhancer hasn't an option to make the windows permanently larger, but you could create a ShellEnhancer task and assign a hotkey to it to resize the active window to a specific size or to maximize it.
Marc Gregoire,
NuonSoft
[ Microsoft MVP VC++ since 2007 ]
User avatar
Marc G
NuonSoft Staff
 
Posts: 826
Joined: Thu Nov 07, 2002 8:19 pm
Location: Belgium

Spoke too soon

Postby shep1549 » Thu Oct 14, 2004 12:17 pm

:cry: Porblem came back after rebooting. But this time I found a resolution right away. I had to rehook the application. Problem was again on save module window of IE. Only this time IE shutdown completely without saving anything. Is there a command line to rehoook on load?
Shep
shep1549
 
Posts: 11
Joined: Fri Oct 08, 2004 12:14 pm

Postby Marc G » Thu Oct 14, 2004 2:52 pm

:(
No there is no command line to rehook.
I'll put it back on the todo and think about it.
Marc Gregoire,
NuonSoft
[ Microsoft MVP VC++ since 2007 ]
User avatar
Marc G
NuonSoft Staff
 
Posts: 826
Joined: Thu Nov 07, 2002 8:19 pm
Location: Belgium

Rehook

Postby shep1549 » Wed Dec 01, 2004 4:25 pm

Finally solved the problemwith Save Dialog. Now I am able to load all the apps that were giving problems. The solution was to uncheck "Enable Shell Enhanced Applications". I don't use this feature so it is no loss to me. No need to rehook either every thing else in your app is working fine now. Course this means you have another boo-boo to fix :D . Sorry.

Let me know if I can be of any help.
Shep
shep1549
 
Posts: 11
Joined: Fri Oct 08, 2004 12:14 pm

Postby Marc G » Wed Dec 01, 2004 4:28 pm

Thanks for letting me know.

Were there Shell Enhanced Applications defined before you unchecked that option or was that listbox in the ShellEnhancer settings under Shell Enhanced Applications empty?
Marc Gregoire,
NuonSoft
[ Microsoft MVP VC++ since 2007 ]
User avatar
Marc G
NuonSoft Staff
 
Posts: 826
Joined: Thu Nov 07, 2002 8:19 pm
Location: Belgium

Sorry for the delay, holidays are busy for me.

Postby shep1549 » Mon Jan 24, 2005 3:17 pm

No I did not have any Shell Enhanced Apps setup. Just the box checked to allow them. Also after rebooting the necessity to rehook SE came back.
I really would like a command line option for that or possibly a way to have it rehook automatically after a set period of time. This could be a config option.
Shep
shep1549
 
Posts: 11
Joined: Fri Oct 08, 2004 12:14 pm

Postby Marc G » Mon Jan 24, 2005 6:11 pm

Strange... I really don't understand this behaviour :(

Are you running Windows XP Home or Professional? There seem to be some problems related to the Home edition that I need to look into.
Marc Gregoire,
NuonSoft
[ Microsoft MVP VC++ since 2007 ]
User avatar
Marc G
NuonSoft Staff
 
Posts: 826
Joined: Thu Nov 07, 2002 8:19 pm
Location: Belgium

Winxp he

Postby shep1549 » Mon Jan 24, 2005 7:07 pm

I am runnging the home edition.
Shep
shep1549
 
Posts: 11
Joined: Fri Oct 08, 2004 12:14 pm

Postby Marc G » Wed Jan 26, 2005 6:14 pm

Thanks for letting me know.
I will need to install a Windows XP Home system and do some bug hunting.
Marc Gregoire,
NuonSoft
[ Microsoft MVP VC++ since 2007 ]
User avatar
Marc G
NuonSoft Staff
 
Posts: 826
Joined: Thu Nov 07, 2002 8:19 pm
Location: Belgium

Next

Return to SE - Bug Reports

Who is online

Users browsing this forum: No registered users and 1 guest

cron