URL wallpaper problem

Here you can report bugs you may find in Wallpaper Cycler.

Moderators: Marc G, Johan G

URL wallpaper problem

Postby dplus » Sun Aug 19, 2007 8:29 am

Hi,
I have version Wallpaper Cycler 3.1.0.39. And have configured a layout with a URL wallpaper (webcam) that refresh every 10 seconds. Everything works fine except when I loose Internet connection temporarily. When the internet connection is lost all URL images are shown black, but when internet connection is restored the images won't wome back. I have to stop and start again the cycling or close the program and reopen it.

My suggestion is that when internet connection is lost the wall paper remains as the las one (instead of black image) and when internet connection is restored, then it continues showing the new images.

Thanks
dplus
 
Posts: 5
Joined: Sun Aug 19, 2007 8:21 am

Postby Marc G » Sun Aug 19, 2007 10:22 am

Thank you for reporting this. I will look into it.
Marc Gregoire,
NuonSoft
[ Microsoft MVP VC++ since 2007 ]
User avatar
Marc G
NuonSoft Staff
 
Posts: 826
Joined: Thu Nov 07, 2002 8:19 pm
Location: Belgium

Postby Marc G » Sun Aug 19, 2007 10:48 am

I just tried to reproduce it, but I can't. For testing I used the following webcam:
http://images.earthcam.com/ec_metros/ou ... eakers.jpg
This is a fast updating webcam, so it's nice to use for testing.
When I disconnect the internet connection, I get a black picture but when I reconnect the internet, it automatically shows me the correct picture again. Note: It might take up to 10 seconds before Wallpaper Cycler will try to download the file again after a download failure.
Marc Gregoire,
NuonSoft
[ Microsoft MVP VC++ since 2007 ]
User avatar
Marc G
NuonSoft Staff
 
Posts: 826
Joined: Thu Nov 07, 2002 8:19 pm
Location: Belgium

The Layout

Postby dplus » Sun Aug 19, 2007 6:52 pm

Marc,
Thanks for your answer. My layout actually is as following. I have 4 webcams in the wallpaper and each webcam is from different source. 10 seconds seems to work sometimes as you say, but try with 1 second refresh and it will not recover. At least it is what's happening to me.

Thanks
dplus
 
Posts: 5
Joined: Sun Aug 19, 2007 8:21 am

Postby Marc G » Sun Aug 19, 2007 7:23 pm

Can you give some of the URLs you are using as webcams?
Marc Gregoire,
NuonSoft
[ Microsoft MVP VC++ since 2007 ]
User avatar
Marc G
NuonSoft Staff
 
Posts: 826
Joined: Thu Nov 07, 2002 8:19 pm
Location: Belgium

Postby dplus » Sun Aug 19, 2007 7:32 pm

dplus
 
Posts: 5
Joined: Sun Aug 19, 2007 8:21 am

Postby Marc G » Sun Aug 19, 2007 8:06 pm

After some more testing I was able to reproduce the issue. There is definitely something wrong in the image downloading part if you download a new image that fast. I'll see if I can still fix it for the next release.
Marc Gregoire,
NuonSoft
[ Microsoft MVP VC++ since 2007 ]
User avatar
Marc G
NuonSoft Staff
 
Posts: 826
Joined: Thu Nov 07, 2002 8:19 pm
Location: Belgium

Postby dplus » Sun Aug 19, 2007 8:11 pm

Marc,
I'm glad you found it. I'm just trying to help to improve this excellent program. I will be waiting for the next release.

Thanks
dplus
 
Posts: 5
Joined: Sun Aug 19, 2007 8:21 am

Another Suggestion

Postby dplus » Mon Aug 20, 2007 4:26 pm

Marc,
May I suggest another thing? I happen to have 2 monitors attached and I have generated a Layout. The same 4 webcams on both monitors. But when I observe the Image Downloading Part I see that it downloads the 4 webcams twice instead of using the same images for both instances. I think it will save time and bandwidth if the Layout analyzes if the image is repeated and it downloads it once every cycle.

Thanks
dplus
 
Posts: 5
Joined: Sun Aug 19, 2007 8:21 am

Postby Marc G » Tue Aug 21, 2007 7:48 am

Sounds an interesting idea, but it will not make it into the next release, because I'm readying the Beta to start the beta phase this week.
Marc Gregoire,
NuonSoft
[ Microsoft MVP VC++ since 2007 ]
User avatar
Marc G
NuonSoft Staff
 
Posts: 826
Joined: Thu Nov 07, 2002 8:19 pm
Location: Belgium


Return to WPC - Bug Reports

Who is online

Users browsing this forum: No registered users and 1 guest

cron