Tile settings not working under Win7 RC

Here you can report bugs you may find in Wallpaper Cycler.

Moderators: Marc G, Johan G

Tile settings not working under Win7 RC

Postby Alinda » Thu Sep 03, 2009 8:49 am

I installed Wallpaper Cycler 3.6 on Win7 RC. I have a two monitor setup with each a different resolution (different types of monitors, same resolution is not an option). This setup worked perfectly under WinXP pro. But now under Win7 RC the screen tiling is all screwed up. It doesn't matter whether I use old layouts or layouts made new.

What I already tried:
1) Clicked the repair tile setting button.
2) Clicked the repair tile setting button, while running Wallpaper Cycler as administrator.
3) Tried the above two with UAC turned off.

The layouts look awful. And I have noticed that, since installing WallpaperCycler, Win7's build-in wallpaper slideshow no longer works.
Alinda
 
Posts: 4
Joined: Tue Sep 01, 2009 1:55 pm

Re: Tile settings not working under Win7 RC

Postby Alinda » Sat Sep 05, 2009 3:16 pm

I looked a bit closer:
The wallpaper slideshow bit is clearly erroneous as today it suddenly worked fine (it is what I use it while WallpaperCycler doesn't work).

Looking at how the layouts are garbled on my screen, I came to the conclusion that the tile settings seem to assume that the left monitor is the primary monitor and the right the secondary. While the layout editor doesn't seem to make that assumption. I haven't tried switching the monitor 1 & 2 setting, because that would be a big inconvenience in my daily usage, I want newly started programs to start on the right monitor (My left monitor I use to display my todolist).

I hope this additional information will help in finding a solution.

PS. I hope there will soon come a better editor for the text parts of the layouts, because ever since switching to 3.6 my 30+ layouts are screwed up (each has 2+ text boxes).
Alinda
 
Posts: 4
Joined: Tue Sep 01, 2009 1:55 pm

Re: Tile settings not working under Win7 RC

Postby Alinda » Sun Sep 06, 2009 10:19 pm

I finally did the experiment of switching the primary monitor to the left monitor, and suddenly the layouts work as they are supposed to work. Though now I keep having to drag programs from one monitor to the other, not ideal! :cry: I hope you will find a solution to this problem.
Alinda
 
Posts: 4
Joined: Tue Sep 01, 2009 1:55 pm

Re: Tile settings not working under Win7 RC

Postby Marc G » Mon Sep 14, 2009 6:22 pm

I´ll take a look at this problem next week when I´m back in the office.
Marc Gregoire,
NuonSoft
[ Microsoft MVP VC++ since 2007 ]
User avatar
Marc G
NuonSoft Staff
 
Posts: 826
Joined: Thu Nov 07, 2002 8:19 pm
Location: Belgium

Re: Tile settings not working under Win7 RC

Postby Alinda » Tue Sep 22, 2009 7:20 am

Thanks!
I really hope you can fix it, because this is driving me nuts.
Alinda
 
Posts: 4
Joined: Tue Sep 01, 2009 1:55 pm

Re: Tile settings not working under Win7 RC

Postby Marc G » Tue Sep 22, 2009 11:52 am

I was able to reproduce your problem on my Windows 7 test setup.
Unfortunately, I don't know how long it will take to fix this :(
Marc Gregoire,
NuonSoft
[ Microsoft MVP VC++ since 2007 ]
User avatar
Marc G
NuonSoft Staff
 
Posts: 826
Joined: Thu Nov 07, 2002 8:19 pm
Location: Belgium

Re: Tile settings not working under Win7 RC

Postby molitar » Mon Jan 18, 2010 5:09 am

Glad your looking into this.. because if I move the secondary monitor to the SW corner than layout is broken.. if I leave the monitor to the SE corner it works perfectly. Seems the layout won't change from the NW/SE layout at all.
molitar
 
Posts: 43
Joined: Sat Apr 08, 2006 5:22 pm

Re: Tile settings not working under Win7 RC

Postby Marc G » Mon Jan 18, 2010 3:22 pm

If you change the setup/orientation/position of your monitors, then yes, you'll need to adjust your layouts accordingly. This is not done automatically.
Marc Gregoire,
NuonSoft
[ Microsoft MVP VC++ since 2007 ]
User avatar
Marc G
NuonSoft Staff
 
Posts: 826
Joined: Thu Nov 07, 2002 8:19 pm
Location: Belgium


Return to WPC - Bug Reports

Who is online

Users browsing this forum: No registered users and 2 guests

cron